Page 1 of 2 1 2 LastLast
Results 1 to 15 of 21
  1. #1
    Registered User
    Join Date
    Dec 2012
    Posts
    2

    How to enable pixel shaders

    You need to have your original disks for this to work. Install ac2 in a folder of your choice. Go to the ac2config.exe and copy it. Next paste it in your downloaded ac2 install folder. Then go into preferences.ini. Scroll all the way to the bottom and look for RunConfigTool=0. Change this to
    RunConfigTool=1 and run ac2. Now when you log in the config program will pop up and you can enable pixel shaders.

  2. #2
    Registered User
    Join Date
    Sep 2010
    Posts
    8

    Re: How to enable pixel shaders

    I'd love to see some before/after pictures. I think I have an old AC2 disc in the attic, but it would be a nightmare to dig out.

  3. #3
    Registered User
    Join Date
    Dec 2012
    Posts
    44

    Re: How to enable pixel shaders

    On a similar note, only not really, I've tried SweetFX and the FXAA tool to try and get post processing effects working in game. It *should* work with Ac2 because it's DX9, but, SweetFX has no effect and FXAA causes the game to crash when launching. Sucks, cause it would make it look very nice indeed. Still trying to figure out why it's not working.

  4. #4
    Registered User Dzapt's Avatar
    Join Date
    Apr 2009
    Posts
    138

    Re: How to enable pixel shaders

    Couldn't you just put the ac2config.exe up for download somewhere? My ac2 discs are long, long gone.
    House of Ordo
    www.ordinem.org

  5. #5
    Registered User
    Join Date
    Dec 2012
    Posts
    29

    Re: How to enable pixel shaders

    I couldn't to get SweetFX to run at all with AC2. But if you could host that file somewhere it would be a great help.

  6. #6
    Registered User
    Join Date
    Dec 2012
    Posts
    44

    Re: How to enable pixel shaders

    I tried the older version of ENB that worked on most games and it doesn't work either. Bummed about this.

    Edit: It appears the SMAA also does not work, so from what I can tell, no post processing stuff works with the game. It should because it's DX9, but it's not. It's possible AC2 is using DX9a and that the post processing stuff requires DX9c...but I'm not sure.
    Last edited by Visceral; 12-15-2012 at 01:31 AM.

  7. #7
    Registered User
    Join Date
    Dec 2012
    Posts
    4

    Re: How to enable pixel shaders

    Quote Originally Posted by Tahnittr View Post
    You need to have your original disks for this to work. Install ac2 in a folder of your choice. Go to the ac2config.exe and copy it. Next paste it in your downloaded ac2 install folder. Then go into preferences.ini. Scroll all the way to the bottom and look for RunConfigTool=0. Change this to
    RunConfigTool=1 and run ac2. Now when you log in the config program will pop up and you can enable pixel shaders.
    Nice find I'll try this out later

  8. #8
    Registered User
    Join Date
    Sep 2006
    Posts
    523

    Re: How to enable pixel shaders

    I would have thought the config tool just updates your preferences.ini ?

    I still have 2 sets of Fallen Kings and Legions discs (just in case I ever found a way to play again, right?) so I'll give it a go later.

  9. #9
    Registered User
    Join Date
    Sep 2010
    Posts
    8

    Re: How to enable pixel shaders

    What Asaron says makes a lot of sense... Tahnittr, can you check your preferences.ini to see if a shaders setting was added by ac2config?

  10. #10
    Registered User
    Join Date
    Dec 2012
    Posts
    7

    Re: How to enable pixel shaders

    here is the tool download :

    http://www.google.com/url?sa=t&rct=j...55325884,d.Yms

    The changes in "Preferences.ini" are:
    [RenderDeviceConfig]
    ForceFixedFunctionPipeline=0

    I'm still not sure this actually changes something, so someone else has to take comparison screen-shots!


    bye Andy


    PS: I also suggest u add a AC2Client profile for your GPU driver, that overrides Anisotropic Filtering to 8-16x and normal AA "enhance 4-8x", don't use FXAA, since its not a deferred renderer! This worked for my nVidia card and AA+Filtering looks much better now.
    I had to turn down the in-game "brightness" setting, since seems gamma gets changed with those changes!
    Last edited by Andy2222; 12-15-2012 at 03:16 PM.

  11. #11
    Registered User slashzero's Avatar
    Join Date
    Oct 2010
    Posts
    136

    Re: How to enable pixel shaders

    I got the configuration tool off my install disks and tried this out. I'm not sure I can tell the difference, other than my FPS dropping a bit. Of course I could just be imagining the frame rate drop. :-)

    Running on 2 ATI 6970s in crossfire mode, with a bulldozer CPU.

    I'll try setting up a custom profile as well to override filtering and anti aliasing, but I thing the game looks outstanding without tweaks too!

  12. #12
    Registered User prjkthack's Avatar
    Join Date
    Sep 2007
    Location
    Kansas City, MO
    Posts
    2

    Re: How to enable pixel shaders

    Took two screenshots, one with Pixel Shaders and one without.

    With PS: https://skydrive.live.com/?cid=2FC11...9D4B121%212351

    Without PS: https://skydrive.live.com/#cid=2FC11...9D4B121%212352

    It kinda looks like the one with PS has a bit more "depth" to it, as in, just in this particular area, the rocks have more of a realistic shape and color to it, where as the one without looks more flat and possibly more washed out.

    These photos were taken in the Esper Vault.

  13. #13
    Registered User
    Join Date
    Jul 2008
    Posts
    36

    Re: How to enable pixel shaders

    Very nice.

  14. #14
    Registered User
    Join Date
    Dec 2012
    Posts
    7

    Re: How to enable pixel shaders

    Quote Originally Posted by prjkthack View Post
    Took two screenshots, one with Pixel Shaders and one without.

    With PS: https://skydrive.live.com/?cid=2FC11...9D4B121%212351

    Without PS: https://skydrive.live.com/#cid=2FC11...9D4B121%212352
    To me it looks like with PS on u get some very basic "bump-mapping" going on, but without actual specular lighting this is a very minor effect.
    I wonder if they actually support shader's or use some old hardcoded stuff, since if they use shader files u could easily just add specular phong lights and do some better bump mapping and overall lighting. Hell we could even get most of the depth based post-process shaders working, so ambient occlusion can work

  15. #15
    Registered User Brokin's Avatar
    Join Date
    Jan 2004
    Posts
    2,925

    Re: How to enable pixel shaders

    LOL,

    This program uses security features of Internet Explorer 6. You need to upgrade Internet Explorer. The installer will now exit.

    (or something like that).

    Anyone else see this error when trying to install from the AC2 Legions disks? Should I be trying from the orniginal launch disks?

    -edit-

    Ok, had better luck with original disks... brought up the config app, but I can't see much difference. I remember human hair having a nice shine to it... still not seeing that... Is it possible that AC2 sees I don't have a descrete graphics card and is downgrading my capabilities? I have a core i7 desktop, so integrated graphics are actually quite good.
    Last edited by Brokin; 12-16-2012 at 09:56 AM.
    AC1: Leafcull - Monarch: Scarey Mary
    --------------------------------
    Brokin - lv275 DualWield(UA)/Life -- GO WOLVERINE!!
    Des Demona - lv264 Heavy-Dagger/AssessC + XBow
    Vexi - lv268 Defensive Finesse Swordie
    Kasta - lv275 BattleMage + MeleeD
    Nayla - lv267 Archer/Life

    AC2:
    --------------------------------
    Fragma - lv42 Tumerok Spear/Healer
    Dezz - lv42 Human Defender
    Nayla - lv38 Human Ranger
    Glyph - lv38 Lugian Sage

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

This form's session has expired. You need to reload the page.

Reload